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Using Aware


Aware is a video player specifically designed for the Motion Pixels codec. There are two versions of Aware, 16-bit and 32-bit.  The 16-bit version of Aware runs under Windows 3.1 and Windows for Workgroups 3.11.  The 32-bit version is designed for the Windows 95 and Windows NT operating system. All the functions described are applicable to the MovieCD Remote Control.








Launching Aware in Windows 3.1 or Windows for Workgroups 3.11





	In the Windows Program Manager, select "File", then "Run"; or click on the Aware icon in the


	Motion Pixels Program Group.





	In the Command Line dialog box, type "C:\MPIXELS\AWARE16.EXE", then click "OK!".





	If Motion Pixels was installed into a different directory, click on the "Browse" button and select the


	appropriate directory.





	The Aware toolbar will pop up.  See the "Loading A Video Clip" section of this documentation


	for further information.








Launching Aware in Windows 95





	In the Windows 95 taskbar, click on the Start Menu, then select "Run"; or click on the Aware icon in


	the Motion Pixels Program Group.





	In the Run dialog box, type "C:\MPIXELS\AWARE32.EXE".  If Motion Pixels has been installed


	into a different directory, type in the appropriate path and filename.
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	The Aware toolbar will pop up.  See the "Loading A Video Clip" section of this documentation for


	further information.
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Loading A Video Clip





	To load a video clip into the Aware program, select "File" in the toolbar, then "Open Video".
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	In the Open dialog box, select the desired video clip from the CD or use "Look In" function to


	browse the directories.  Click on a file with the .AVI file extension. 
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	The first frame of the video clip will load into the window.  The filename of the video clip is


            displayed in the titlebar at the top of the window.  To play the video in the original-sized window,


            click on the play arrow in the lower left-hand corner or press CTRL+P on the keyboard.  Use the


            slider bar to advance through the video frames.  To play in the video in a window using the


            MovieCD program, click on the Play button on the Remote Control.
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	The video segment can be played directly in a window or in full screen mode.  There are several


            playback options available, accessible through the Playback Style dialog box.  To open this dialog


            box, select "File" in the toolbar, then Playback Style or press CTRL+L on the keyboard.  In the


            MovieCD program, click on the Playback Style button on the Remote Control. 
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	The MVI Configuration dialog box contains 13 different options for playing the video in a window


            or full screen.
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Below is a detailed explanation of the Motion Pixels resizing techniques.  Each resizing technique can be


applied to either the full screen or windowed enlargement styles.





The default Minimum Fullscreen Resolution is 640x480 pixels.  The default Windowed Enlargement Style


is dependent on system factors such as processor speed and operating system. The default Fullscreen Enlargement Style is 4x Pattern Enlargement in 256 color mode.





The Windowed Enlargement Styles that are grayed out become available when the desktop color palette is


set to 256 colors.





Any of the Windowed or Fullscreen Enlargement Styles may be used, although some video adapters may


not support all playback modes.





Motion Pixels (MVI) Playback Style Configuration - Resizing Options





32k/64k (Hicolor) Methods


No Enlargement	Video retains its original (captured) size.


Single Field	Video retains its original size, but odd fields are removed for fastest playback.


	Use this mode on slower computers to improve playback performance.


Wide Field Lines	Video plays back at twice the horizontal resolution. This mode is


	similar to single-field, but doubles the vertical pixels.


4x Pixel Enlargement	Video plays back four times its original size in 32,768 colors (regardless of 


	video adapter).


4x Horizontal Lines	Video plays back four times its original size in 32,768 colors (regardless of 


	video adapter), providing horizontal color enhancement.


4x Pattern Enlargement	Video plays back four times its original size in 32,768 colors (regardless of 


	video adapter).  Antialiasing smoothes an image which contains areas of high 


	contrast.


9x Pattern Enlargement	Video plays back nine times its original size.





256 Color (Palletized) Methods


4x Pattern Enlargement	Video plays back in 256 colors at 4 times its original size with improved


	playback performance compared to 4x Hicolor mode.  Antialiasing smoothes


	an image which contains areas of high contrast.


9x Pattern Enlargement	Video plays back in 256 colors at 9 times its original size.  Works well for


	160x120 video clips.





256 Color (Grayscale) Methods	


No Enlargement	Video plays back at original size in black and white.


4x Pixel Enlargement	Video plays back at 4 times original size in black and white.


4x Pattern Enlargement	Video plays back at 4 times original size in black and white.  Antialiasing


	smoothes an image which contains areas of high contrast.


9x Pattern Enlargement	Video plays back at 9 times original size in black and white.





Use Hardware Scaling (if available)


Hardware Scaling	Hardware scaling enables the video window to be resized to any dimensions.


	If a video adapter (i.e. Weitek) has video acceleration capabilities, the video


	in a window will play much faster.  Checking this option disables all other


	video resizing techniques in a window.








Advance Configuration


The Advanced Options section allows the user to fine-tune the Motion Pixels performance:
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	The Optimize For No Cache check box should be selected for computers that have 128Kb of level


	two (L2) cache or less.





	Motion Pixels uses the standard Windows AVI video file format.  Selecting the Disable Auto-


	Resizing allows the video to be resized or "stretched" in another application such as Media Player.





	Save Video State ensures the Windows desktop is not corrupted after playing the video full screen


	at the expense of a small amount of video memory.





	Maximum Video Quality smoothes out blocky areas of video that contains massive amounts of 


	blue.  This function is extremely CPU-intensive.  A Pentium 100Mhz or higher is recommended.





	Disable Linear Video re-enables bank-switching for video adapters that may use VESA 2.0


	drivers.  Use this function if your full screen video does not function correctly.





	If the video adapter chipset is not known, pressing the Detect Video Chipset button will perform a


	diagnostic routine to determine the chipset type.  the "Automatically Detect" option is selected by


	default.  Under normal circumstances, it will not be necessary to change this setting.





	The Gamma and Brightness Sliders can be adjusted the overall brightness and color saturation of 	the video.  See the Effect section for more information.





	The Reset Gamma & Brightness button returns these settings to their default values.





Click on "Ok!" when selections are complete to close this dialog box.





Player Options





	Motion Pixels offers several other options for video playback.  In the "File" menu in the Aware


            toolbar, select "Player Options", click the "Options" button on the Remote Control or press


            CTRL+T on the keyboard to access the Playback Options.  Click on "OK" when completed.
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The Rewind/Fast Forward speed can be adjusted from 2.5 times original speed up to "Fast As Possible


Without Skipping Frames".





The audio can be muted during rewind, fast-forward, or slow-motion functions.





Replay Video restarts from the beginning after  the video has played through to the end.  Looping is enabled by default.





Always On Top keeps the video window on top of other open applications, such as a spreadsheet or


word processing program.





Boost Priority allocates most of the system resources to video playback with other applications open.








Aware Control Functions


The Control Menu in the Aware toolbar accesses the video playback functions.  Each functions has an


associated hotkey listed next to it.  In the MovieCD program, click on the associated button on the


Remote Control.
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Play In Window (CTRL+P) - Plays the video forward at normal speed in a window.





Play Fullscreen (CTRL+F) - Launches the video in full screen mode according to the


Fullscreen Enlargement Style.





Slow Motion (CTRL +S) - Plays the video in a window forward at 1/4 normal speed.





Stop (ESC) - Stops the current playback of the video in a window.





Minus 1 Frame (<-) - Reverses the video in the window backwards one frame at a time.





Plus 1 Frame (->) - Advances the video in the window forward one frame at a time.





Minus 15 (PAGEUP) - Reverses the video in a window backwards 15 frames (1 second) at a time.





Plus 15 (PAGEDOWN) - Advances the video in a window forward 15 frames (1 second) at a time.





Goto Start (HOME) - Jumps to the first frame of the video in a window.





Goto End (END) - Jumps to the last frame of the video in a window.





Rewind (CTRL+<-) - Reverses the video in a window at the selected rewind/fast-forward speed.





Fast Forward (CTRL+->) - Advances the video in a window at the selected rewind/fast-forward speed.





GoTo (CTRL+G) -  The GoTo function displays the Current Frame, Total Number Of Frames, and desired


GoTo Frame.  Type in the frame number that you wish to go to up to the length of the video. If the value


entered is greater than the total length of the movie, the time will jump to the last frame of video.





Replay (CTRL+R) -   The Replay dialog box contains user-definable options for specifying start and end looping points.  This function works with both the windowed and full-screen video modes.








The Effects Menu


The Effects menu allows the user to control gamma levels, brightness levels, or master volume levels, as


well as audio mute functions.  Please note that these functions are only available under Windows 95.
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Gamma increases or decreases the various levels of gray in the video in a non-linear fashion without


affecting the levels of the pure black and white signals.  Brightness, on the other hand, changes all the


video levels evenly, or in a linear fashion.  Use these controls to compensate for darker monitors, LCD


displays, etc.





Gamma Decrease ( { ) -  Decreases the gray levels without affecting the pure black and white levels.


Gamma levels can also be adjusted with the slider bars in the Advanced Options dialog box


under Playback Style.





Gamma Increase ( } ) - Increases the gray levels without affecting the pure black and white levels.


Gamma levels can also be adjusted with the slider bars in the Advanced Options dialog box


under Playback Style.





Gamma Reset ( | ) - Resets the gamma levels to their default value of 1.00.  Gamma levels can also be reset with the "Reset Brightness & Gamma" button in the Advanced Options dialog box.





Brightness Decrease ( [ ) - Decreases the overall white level of the video signal.  Setting too


low a value will darken the video with loss of details.





Brightness Increase ( ] ) - Increases the overall white level of the video signal.  Setting too


high a value will wash out the colors of the video.





Brightness Reset ( \ ) - Resets the brightness levels to their default value of  zero. Brightness


levels can also be reset with the "Reset Brightness & Gamma" button in Advanced Options dialog box.





Volume Decrease ( , or SHIFT+<) - Lowers the master volume mixer control in the Windows 95 taskbar.


The sound card must have a properly-installed mixer control driver for volume controls to function.





Volume Increase (. or SHIFT+>) - Raises the master volume mixer control in the Windows 95 taskbar.


The sound card must have a properly-installed mixer control driver for volume controls to function.





Mute\Unmute ( / or SHIFT+?) -  Silences the audio during video playback. This function works with


either full-screen or windowed video.








The Help Menu


The Help Menu displays a dialog box indicating the location of the information files in the Motion Pixels


folder , Video Status and Player/Codec Versions.





Aware Help - Click on this menu option to launch the Windows help dialog box.





Status - Indicates if a DCI video driver is enabled.





About Player - Displays developer information, copyright information, and current version number.





About the Motion Pixels Codec - Displays developer information, copyright information, and current


version number.








